US Email Sends Sitting in Pending Status
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Jul 02, 2020 - 15:50 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 02, 2020 - 15:46 UTC
Investigating
We are currently investigating this issue.
Posted Jul 02, 2020 - 15:33 UTC
This incident affected: US Data Center (Email).