Campaign Automation Progression Delays
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted May 26, 2020 - 16:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 26, 2020 - 13:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 26, 2020 - 13:15 UTC
Investigating
We are currently investigating this issue.
Posted May 26, 2020 - 13:06 UTC
This incident affected: US Data Center (Campaign Automations).