(CAN) Email Events Not Syncing
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 14:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2020 - 12:30 UTC
Investigating
We are currently investigating this issue.
Posted Mar 25, 2020 - 12:02 UTC
This incident affected: CAN Data Center (Email).