Inboxcast emails return with the 'your message couldn't be delivered' error.
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 14:19 UTC
Investigating
We are aware of the issue with Inboxcast not sending emails and returning with the 'your message couldn't be delivered' error, and are actively working to bring the service back to working state.
Posted Feb 06, 2023 - 12:02 UTC
This incident affected: US Data Center (Email), EU Data Center (Email), AU Data Center (Email), and CAN Data Center (Email).