US Campaign Automation Participant Addition and Progression Delays
Incident Report for ClickDimensions
Postmortem

After investigation we have determined the root cause of this to be a code issue that impacted multiple areas of our platform in our US data center. Customers may have seen this issue display in Campaign Automations, Form Submissions, Email Sends.

A fix has already been developed and we do not expect this issue to reoccur.

If you experienced an odd behavior with the platform between 9am UTC October 6 and 9am UTC October 7 and are hosted on our US data center, it may be related to this issue.

Posted Oct 07, 2021 - 16:34 UTC

Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 12:32 UTC
Update
We continue to monitor for further issue. We have confirmed that participants added to Automations but not appearing in the participant list will appear in the participant list over the next few hours. We recommend that customers not re-add participants to their Automations.
Posted Oct 06, 2021 - 20:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 06, 2021 - 19:46 UTC
Identified
The issue has been identified and we are working to implement a fix. Some editors and designers may not load while the fix is deployed. Please wait 5 minutes and try to load the pages again.
Posted Oct 06, 2021 - 19:25 UTC
Update
We are continuing to investigate this issue.
Posted Oct 06, 2021 - 19:05 UTC
Investigating
We are currently investigating an issue where participants may be delayed in progressing and/or being added to Campaign Automations.
Posted Oct 06, 2021 - 17:55 UTC
This incident affected: US Data Center (Campaign Automations).