EU Profile Management Sync Delays
Incident Report for ClickDimensions
Resolved
We identified a high load in the profile management data sync service. We isolated the cause of the error and scaled our resources to compensate for the load. If you continue to experience difficulties please contact ClickDimensions support.
Posted Dec 02, 2020 - 23:41 UTC
Investigating
We are investigating an issue causing delays in the Profile Management Data Sync service.

How to know if you're impacted:

If using profile management, check if data is syncing in a timely manner.
Posted Dec 02, 2020 - 14:26 UTC
This incident affected: EU Data Center (Forms).