elinkeu.clickdimesnions.com certificate expired
Incident Report for ClickDimensions
Resolved
The certificate has been restored and the issue is resolved. Links should work as expected at this time.
Posted Jan 24, 2022 - 14:41 UTC
Identified
We have identified an issue in the EU data center wherein links utilizing elinkeu.clickdimensions.com are showing error messages due to an expired certification. This mostly includes links added into emails using ClickDimensions tracking functionality. Our team is working to resolve this issue as quickly as possible.

Possible workaround: it is possible for the impaired links to still be accessed. The end user will have to navigate their browser's error message and choose to proceed to the provided link.
Posted Jan 24, 2022 - 13:18 UTC
This incident affected: EU Data Center (Email, Forms, Landing Pages, Subscription Management, Surveys).