Customer Support Chat Issues
Incident Report for ClickDimensions
Resolved
Our Chat provider has indicated that the issue is now resolved and support chat should be working as expected.
Posted May 11, 2021 - 16:07 UTC
Identified
We are aware of an issue regarding the ability for customers to submit and be served via Chat. Our chat provider has acknowledged the problem and is working towards resolution. We recommend customers submit tickets via this link: https://support.clickdimensions.com/hc/en-us/requests/new?ticket_form_id=114093987733
Posted May 11, 2021 - 15:32 UTC
This incident affected: ClickDimensions Help Site.