EU Campaign Automation Participant Progression Delays
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Jan 23, 2020 - 18:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 17, 2020 - 13:37 UTC
Investigating
We are currently investigating this issue.
Posted Jan 16, 2020 - 13:58 UTC
This incident affected: EU Data Center (Campaign Automations).