EU Email Delays
Incident Report for ClickDimensions
Resolved
The service continues to function as expected after restart. If you continue to experience any difficulties please reach out to ClickDimensions Support.
Posted Mar 03, 2021 - 15:46 UTC
Monitoring
We have identified and restarted the service causing the issue. Emails should now be delivering as expected.
Posted Mar 02, 2021 - 20:41 UTC
Investigating
We are investigating an issue causing delays in email sends from the EU datacenter
Posted Mar 02, 2021 - 19:06 UTC
This incident affected: EU Data Center (Email).