Email send delays in EU region
Incident Report for ClickDimensions
Resolved
Email Send functionality should be returned to a normal, expected state. Please contact ClickDimensions Support if you experience further issues.
Posted Jan 21, 2022 - 15:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 21, 2022 - 13:20 UTC
Identified
We're experiencing some impact on the email service in EU region. As a result, you may see your Email Sends being delayed.
Posted Jan 21, 2022 - 12:49 UTC
This incident affected: EU Data Center (Email).