We have identified and resolved the issue that was preventing the Designers from loading in Click. All services are now functioning as expected. Our team will continue to monitor the platform closely to ensure stability. Thank you for your patience during this time.
Posted Apr 11, 2025 - 16:42 UTC
Update
We are continuing to investigate this issue.
Posted Apr 11, 2025 - 16:30 UTC
Investigating
We are currently experiencing an issue affecting the Form and Email Designers within the US Region "Authorization Error - Please close the window and relaunch the editor". Users may be unable to load these tools, which could impact the ability to create or edit forms and email templates. Our team is actively investigating the issue and working to restore full functionality as quickly as possible. We will provide updates as more information becomes available. Thank you for your patience.
Posted Apr 11, 2025 - 15:55 UTC
This incident affected: US Data Center (Email, Forms, Landing Pages, Surveys).