Email send delays - US Data Centre
Incident Report for ClickDimensions
Resolved
We have identified an influx in problematic emails being sent out. The affected emails have been moved to a dedicated queue and are still being processed separately to allow new sends to send out. You should be experiencing normal behavior when sending new emails. If you continue to experience any difficulties, please reach out to ClickDimensions Support.
Posted Mar 03, 2021 - 18:13 UTC
Monitoring
We have identified an influx in problematic emails being sent out. These have been moved to a dedicated queue to allow new sends to send out. You should be experiencing normal behaviour when sending emails.
Posted Mar 03, 2021 - 15:43 UTC
Investigating
We are investigating an issue causing delays in email sends from the US Datacenter
Posted Mar 03, 2021 - 11:35 UTC
This incident affected: US Data Center (Email).