EU Import Tool failing to Import Records
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Dec 03, 2019 - 19:57 UTC
Investigating
We are currently investigating this issue.
Posted Dec 03, 2019 - 17:53 UTC
This incident affected: EU Data Center (Import Tool).