US Email Sends displaying Error Recovery Status
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Mar 27, 2020 - 14:42 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 26, 2020 - 11:27 UTC
Monitoring
A fix has been implemented and we are monitoring results. New sends should process and send immediately, but emails with error recovery status may take multiple hours to process and send.

If a send that current has error recovery status needs to be sent immediately, please clone the email send record, delete the original, and then send the clone.

If you do not delete the original email send after cloning, the email could be sent twice.
Posted Mar 23, 2020 - 21:43 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 23, 2020 - 21:34 UTC
Investigating
We are currently investigating an issue where US Email Sends may sit in 'Error Recovery' status. Our team is urgently investigating and we will provide updates here as they become available.

Customers should not resend these emails as the emails are queued up and could still process. If customers do not want these emails to send, please delete the email send record from CRM as this will cause the email to fail when the send attempts to process again.
Posted Mar 23, 2020 - 20:27 UTC
This incident affected: US Data Center (Email).