S2 Service Incident - Intelligent Dashboards unavailable

Incident Report for ClickDimensions

Resolved

Cloudflare have confirmed that the issue has been resolved, and we have confirmed that Intelligent Dashboards is back online.
Posted Nov 18, 2025 - 14:41 UTC

Update

We are actively monitoring progress with Cloudflare to resolve the underlying issue, as their global outage is the root cause of the disruption. They are actively working to restore service, and once their systems return to normal, Click services impacted by this dependency will recover accordingly.
Posted Nov 18, 2025 - 14:09 UTC

Investigating

Click is currently investigating an S2 Service Incident affecting Intelligent Dashboards in all regions, caused by a global Cloudflare outage. Users may see an Internal Server Error when attempting to access Dashboards, and no workaround is available at this time. We are monitoring progress from Cloudflare and will share additional updates when available.
Posted Nov 18, 2025 - 13:29 UTC
This incident affected: ClickDimensions Intelligent Dashboards.