Authentication Errors US Data Center
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Mar 07, 2024 - 22:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 07, 2024 - 21:43 UTC
Investigating
We are currently investigating an issue where customers in our US data center may see errors when accessing specific aspects of the ClickDimensions product. Our team is working to address the issue now.
Posted Mar 07, 2024 - 21:42 UTC
This incident affected: US Data Center (Campaign Automations, Email, Email Statistics, Forms, Landing Pages, Lead Scoring, Marketing Calendar, Subscription Management, Surveys, Web Tracking).