The issue has been resolved. Our partners have confirmed that any previously affected data has been successfully reprocessed, with no data loss identified. All services are operating normally.
Posted Oct 20, 2025 - 16:22 UTC
Update
We’re seeing continued recovery, with affected services now operating normally. As a result, we’ve updated the impacted components to Operational. AWS continues to report significant progress toward full resolution, and we’ll provide a final update once full confirmation of resolution has been received.
Posted Oct 20, 2025 - 10:45 UTC
Update
We are seeing continued recovery, with most services now operational and performing as expected. Some users may have experienced brief delays in data syncing earlier, but no data loss has been observed. We are closely monitoring all systems and coordinating with other partners who utilise AWS services to confirm full restoration, and will provide further updates as they become available.
Posted Oct 20, 2025 - 10:33 UTC
Monitoring
We’ve received an update from AWS indicating ongoing recovery, and most services are now operating normally with remaining queued requests processing successfully. Our team continues to monitor performance to ensure full recovery, and we’ll provide further updates as they become available.
Posted Oct 20, 2025 - 09:58 UTC
Investigating
We are currently experiencing an issue affecting Page views and Form submissions in the US region due to a widespread AWS outage impacting multiple companies globally. Other services, including Email Events, remain operational but may experience delays if the outage persists. Our engineering team is monitoring the situation closely and will provide updates as they become available.
Posted Oct 20, 2025 - 09:51 UTC
This incident affected: US Data Center (Email Statistics, Forms, Web Tracking).