(500) Internal Server Error when opening Campaign Automations - EU

Incident Report for ClickDimensions

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 17:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2025 - 14:27 UTC

Investigating

We are currently investigating an issue within the EU data centre related to the following error encountered when opening Campaign Automation builders: “(500) Internal Server Error.”
Posted Jun 27, 2025 - 10:35 UTC
This incident affected: EU Data Center (Campaign Automations).