Inbox Preview functionality currently unavailable
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Jan 27, 2025 - 15:28 UTC
Investigating
We are currently investigating an issue impacting the Inbox Preview feature and are working with our third-party provider to resolve this.
Posted Jan 27, 2025 - 12:17 UTC
This incident affected: US Data Center (Email), EU Data Center (Email), AU Data Center (Email), and CAN Data Center (Email).