Delays in accessing the Landing page Editor (EU Region)

Incident Report for ClickDimensions

Resolved

We are pleased to inform you that the service incident affecting the Landing Page Editor in the EU region has been resolved. Users should now be able to access this feature without any delays. We appreciate your patience and understanding during this time. Should you experience any further issues, please do not hesitate to contact our support team.
Posted Apr 28, 2025 - 09:23 UTC

Investigating

EU based customers are currently experiencing delays in accessing the Landing Page Editor. Our technical team are actively working to resolve this issue as quickly as possible. We apologise for any inconvenience this may cause and appreciate your patience. We will provide updates as soon as we have more information.
Posted Apr 28, 2025 - 08:12 UTC
This incident affected: EU Data Center (Landing Pages).