Enhanced email template view not loading - US and EU data centre

Incident Report for ClickDimensions

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 14:47 UTC

Identified

We are currently aware of an issue with the "Enhanced" view of the Email Template section which is currently not loading properly, impacting EU and US data centre customers. As a workaround, switch the "Enhanced" view to "Classic" which will allow you to edit your template as normal whilst our team are working on a fix for the "Enhanced" template view section.
Posted Aug 22, 2025 - 13:02 UTC
This incident affected: US Data Center (Email) and EU Data Center (Email).