US Email Delivery Delays
Incident Report for ClickDimensions
Resolved
This incident has been resolved. Some residual issues were resolved by 6:35 PM EDT on 7/19 and the entire backlog was cleared by 8:00 PM EDT.
Posted Jul 19, 2024 - 12:01 UTC
Monitoring
The issue has been identified and we are monitoring the progress of the fix. Based on the findings, emails that experienced a delay will process in time. Delays of around 2 hours can be expected for any emails that have not processed.
Posted Jul 18, 2024 - 19:09 UTC
Investigating
We are currently investigating an issue with email delivery delays in our US data center. This delay is only impacting a subset of accounts. If you experience delays, we recommend not to re-send your emails as this may lead to duplicate deliveries.
Posted Jul 18, 2024 - 17:24 UTC
This incident affected: US Data Center (Email).