Scheduled Maintenance - EU Data Centre

Incident Report for ClickDimensions

Resolved

The problem has now been identified and resolved in partnership with Microsoft. We appreciate your patience while we worked through this issue. We are working on conducting a full root cause analysis (RCA) in partnership with Microsoft, and this can be shared if requested from Click Support.
Posted Aug 28, 2025 - 10:37 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 28, 2025 - 08:06 UTC

Identified

Following scheduled maintenance on the EU Data Centre, We are aware of reports impacting the below entities which may be experiencing degraded performance as a result. We apologise for any business disruption as we work to resolve:

Forms & Pageview Syncing
Online Survey Designer
Preference Center Designer
Form Designer or accessing forms on your website throwing up a Gateway Error
Email & SMS within Campaign Automations
Email Event Syncing
Score Syncing
Segmentation Syncing
Campaign Automation Participants will not proceed past entry point triggers
Email Designer
Landing Page Editor
Posted Aug 28, 2025 - 07:45 UTC
This incident affected: EU Data Center (Email, Email Statistics, Landing Pages, Lead Scoring, SMS, Subscription Management, Surveys, Web Tracking).