A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2024 - 11:48 UTC
Update
Our team is continuing to work on a fix for this issue. We have narrowed the scope of the issue considerably. At this point only newly created Campaign Automations are consistently not loading their builders. Existing Campaign Automation should load with slight delays.
We have also identified a workaround should you need to open a new Campaign Automation record and builder. When an existing Campaign Automation is cloned, the builder for the new cloned record will load with after a slight delay. Once the cloned record is created, you will be able to edit both the record in Dynamics and the canvas in the builder. Please reach out to ClickDimensions Support if there is any difference between your experience and the behaviors as described here.
Posted Jun 21, 2024 - 18:44 UTC
Identified
We have identified the source of the issue and are developing a fix.
Posted Jun 21, 2024 - 13:34 UTC
Update
Our team has seen improved performance for opening existing Campaign Automation records. We are still seeing intermittent issues opening the builder for newly created records and we are continuing to investigate.
Posted Jun 21, 2024 - 12:52 UTC
Investigating
We are currently investigating an issue with Campaign Automation Builders failing to load.
Posted Jun 20, 2024 - 10:30 UTC
This incident affected: CAN Data Center (Campaign Automations).