S1 - Service Incident - Email Sends Not Delivering - US Region

Incident Report for ClickDimensions

Resolved

This incident has now been resolved. We identified an issue that resulted in an increase in the Error Recovery queue and have implemented a fix. Email sends should now be processing normally.

Customers may have experienced delays with email sends during the morning of 11 September 2026 (EST). Any impacted emails should now be processing and delivering as expected.

If you have any questions or continue to experience issues, please contact Click Support for assistance.
Posted Sep 11, 2026 - 16:24 UTC

Investigating

We are aware of an issue currently affecting email send processing for some customers in the US data centre. Emails are not currently being processed for delivery, resulting in delayed or undelivered email sends.

We recommend that customers do not resend emails at this time, as sends may still process once the issue is resolved and duplicate sends could occur if emails are resent.

Our engineering team is actively investigating the issue and working to restore normal operation as quickly as possible. Further updates will be provided as more information becomes available.
Posted Sep 11, 2026 - 16:01 UTC
This incident affected: US Data Center (Email).