Twitter/X Posting Failure due to external API Issue

Incident Report for ClickDimensions

Resolved

We can confirm that the API outage was resolved by X, and a further backend fix to address the media upload issue has been implemented. While occasional transient errors may still occur, they are now rare. We will continue to monitor the situation closely.
Posted Jun 04, 2025 - 09:35 UTC

Monitoring

We are currently aware of an issue affecting the publishing of posts to Twitter/X through our Social Platform. This issue has been traced to a problem with X's API and is not related to Click. However, we are monitoring the situation and will provide updates as they become available.
Posted Jun 03, 2025 - 15:37 UTC
This incident affected: Third Party Components (OktoPost).