We’ve confirmed that email delivery performance has returned to normal. The previously implemented traffic adjustments (put in place at 12:30 PM ET on January 21) successfully mitigated the delays, and new messages are now sending and delivering as expected. Any messages that were already queued prior to this change have completed their retry cycles and are no longer experiencing delays. We continue to monitor Gmail and Google Workspace delivery to ensure stability and consistency. At this time, no further customer action is required. Thank you for your patience while we worked to resolve this issue.
Posted Jan 22, 2026 - 17:19 UTC
Monitoring
We have confirmed that the delivery delays are tied to a Google-initiated rate limiting action affecting a specific Click IP address. The previously implemented traffic rerouting (implemented at 12:30 PM ET on January 21) remains in effect and continues to improve delivery success for newly sent messages. Messages that entered queues prior to the mitigation may still experience delays until retries complete and queues fully clear. We are continuing close monitoring of Gmail and Google Workspace delivery performance and remain actively engaged with Google to address the underlying trigger and prevent recurrence.
Posted Jan 22, 2026 - 10:22 UTC
Update
Our email partners have taken steps to mitigate the impact by rerouting the majority of outbound traffic away from the affected sending infrastructure for messages sent. This should help improve delivery success for new sends while we continue to address the situation.
Messages that were already queued prior to this change will continue retrying through their original paths until those queues naturally clear.
We remain in active communication with our email partners to identify and resolve the underlying issue. In the meantime, these adjustments are intended to reduce disruption and allow sending to continue more successfully.
We’ll continue to provide updates as more information becomes available, and we appreciate your patience while we work through this.
Posted Jan 21, 2026 - 18:45 UTC
Investigating
We are currently investigating an issue involving increased email bounce rates impacting some customers sending to Gmail accounts. Our teams are actively working to understand the cause and are working with Gmail directly to work on a solution. We will continue to update as updates become available.