Service Incident - (US) 500 Internal Server Error
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 21:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2020 - 21:49 UTC
Investigating
We are currently investigating this issue.
Posted Jun 26, 2020 - 21:22 UTC
This incident affected: US Data Center (Campaign Automations).