S2 Service Incident - Inbox Previews are not generating - All Regions

Incident Report for ClickDimensions

Resolved

We can confirm that the issue affecting the Inbox Preview feature has been resolved and all related services are fully restored.
Posted Dec 04, 2025 - 14:31 UTC

Monitoring

We have applied a fix that has restored Inbox Preview functionality. The service is now operating as expected, and we will continue to monitor performance to ensure stability.
Posted Dec 04, 2025 - 13:31 UTC

Investigating

We are currently experiencing an issue impacting the Inbox Preview feature. Users may experience that previews are not generating as expected after domain selection. Our team is actively working to resolve the issue. Updates will be posted here as they become available.
Posted Dec 04, 2025 - 12:39 UTC
This incident affected: US Data Center (Email), EU Data Center (Email), AU Data Center (Email), and CAN Data Center (Email).