Campaign Automation Participant Progression Delays
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted May 21, 2020 - 22:11 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 21, 2020 - 21:14 UTC
This incident affected: US Data Center (Campaign Automations).