Email Sends Failing in Canada
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Sep 13, 2020 - 17:59 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 13, 2020 - 17:54 UTC
Investigating
We are currently investigating this issue.
Posted Sep 13, 2020 - 17:20 UTC
This incident affected: CAN Data Center (Email).