S2 Service Incident - Increased bounce rates when sending to Gmail (non EU customers)

Incident Report for ClickDimensions

Update

We are continuing to investigate this issue - Note, this is not affecting EU based customers at this time.
Posted Feb 23, 2026 - 16:31 UTC

Update

We are continuing to investigate this issue.
Posted Feb 19, 2026 - 17:09 UTC

Update

We are continuing to investigate this issue.
Posted Feb 19, 2026 - 17:06 UTC

Investigating

We are investigating an issue involving increased email bounce rates impacting some customers sending to Gmail accounts. Our teams are aware and are working with Gmail directly to work on a solution. We will continue to update as updates become available.
Posted Feb 17, 2026 - 14:30 UTC
This incident affects: US Data Center (Email), AU Data Center (Email), and CAN Data Center (Email).