Form Submission Delays in the EU Data Center.
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Feb 20, 2025 - 09:50 UTC
Monitoring
We can see the syncing of Form Submissions has returned to a normal state. We will continue to monitor this over the next couple of hours.
Posted Feb 19, 2025 - 12:21 UTC
Identified
The issue has been identified and the investigation is ongoing.
Posted Feb 19, 2025 - 09:30 UTC
Investigating
We are currently investigating an issue with Form Submissions in the EU Data Center. During this time, customers may experience a delay in the creation of a form submission record in CRM.
Posted Feb 18, 2025 - 16:33 UTC
This incident affected: EU Data Center (Forms).