Service Incident - (CA) NEW Drag & Drop Editor - Unexpected Error Occurred
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 14:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2020 - 11:26 UTC
Investigating
We are currently investigating this issue.
Posted Jun 24, 2020 - 21:02 UTC
This incident affected: CA Data Center (Email).