Email Send Delays on US Data Centre

Incident Report for ClickDimensions

Resolved

The recent service incident affecting Click has been fully addressed. Our teams implemented corrective actions, and all services are now operating normally. We are preparing a Root Cause Analysis (RCA) to share with affected customers directly. No further action is required at this time.
Posted Aug 21, 2026 - 21:54 UTC

Investigating

We are aware of an issue currently causing delays in email processing for some customers in the US data centre. Emails are queued for processing and may take longer than normal to be delivered.

We recommend not resending emails, as queued Emails will continue to process automatically and duplicate sends may occur if Emails are resent. Our engineering team are reviewing this and are working on a fix.
Posted Aug 21, 2026 - 13:27 UTC
This incident affected: US Data Center (Email).