Incident Description: Embedded forms as widgets (created prior to Jan 31st 2021) not loading with 404 not found error.
Issue Summary: On Friday 13th December 2024 – Microsoft issued an advisory that one of their partners who managed historical Content Delivery Network (CDN) URL’s were being retired urgently. On Thursday 19th December, a further advisory was issued that the partner had entered chapter 11 bankruptcy proceedings in the US. This partner was used with embedded Click forms as widgets created BEFORE January 31st 2021.
Since February 1st 2021 – all embedded forms as widgets have been created with the Microsoft native CDN service URL’s. All content is also present within our Microsoft native CDN service – however, embedded forms created before this date still used the historical URL.
On Friday 20th December 2024 – the historical URL service unexpectedly failed and our advice from Microsoft is to remove all references to the historical URL to restore normal service.
Am I impacted? If you have an active, embedded form as a widget that was created before January 31st , 2021, then you are likely seeing this form has a 404 not found error when trying to load. Further checks of the HTML code embedded from Click will show you have this URL reference - https://az551914.vo.msecnd.net.
Resolution: If you have an embedded form as a widget created before January 31st 2021 – the fix is to go through the standard publishing steps for an embedded form as a widget – this will provide the URL to the native Microsoft service and your forms will resume after publishing the update. More information on how to complete this step is here: https://support.clickdimensions.com/hc/en-us/articles/115001163194-Embedding-Web-Content
Have I lost any data? No, all forms are stored securely in our content delivery network hosted in Microsoft Azure. No data has been lost.
Why has this only just become an issue? Click took steps in 2021 with all embedded forms issued after this point having native CDN URL’s. We had a program of activity for Q1 / Q2 2025 to reach out to customers and move their content gradually over time. The Chapter 11 notice was unexpected and the impact to services was immediate.
What specifically was impacted? Embedded forms as Widgets created before January 31st 2021 – this is the only service impacted.
Is there anywhere else I can get information from Microsoft on this failure? Yes – here is the current retirement notification from Microsoft regarding Edgio CND services. At time of writing, the FAQ section highlights that the original retirement date was November 2025. https://learn.microsoft.com/en-us/azure/cdn/edgio-retirement-faq
Posted Dec 22, 2024 - 17:44 UTC
Identified
At this time we have observed some customer experiencing issues with embedded forms not loading. This appears to be impacting legacy forms only and not forms created on Clicks newer Form Designer. The issue appears to be linked to a change in Microsoft’s Content Delivery Network (CDN). We are actively working with Microsoft to determine whether this was an intentional update, a temporary adjustment, or an unintentional issue on their end. Rest assured we are hard at work to address and resolve the issue as soon as possible.
Posted Dec 20, 2024 - 19:40 UTC
This incident affected: US Data Center (Forms), EU Data Center (Forms), AU Data Center (Forms), and CAN Data Center (Forms).