US Email Sends Opening New Template Builder When Using Drag and Drop
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 19:50 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2023 - 14:37 UTC
Investigating
We are currently investigating an issue causing email sends to open a new template builder and/or take a prolonged amount of time when attempting to add an existing Drag and Drop template to an email send, as opposed to adding the existing template as expected.
Posted Nov 21, 2023 - 13:19 UTC
This incident affected: US Data Center (Email).