Campaign Automation builder showing The remote server returned an error: (500) Internal Server Error or loading indefinitely
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 10:50 UTC
Investigating
We are currently investigating this issue.
Posted Jun 01, 2020 - 09:06 UTC
This incident affected: EU Data Center (Campaign Automations).