Forms not Syncing to CRM
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 16:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 21, 2020 - 16:14 UTC
Investigating
We are currently investigating this issue.
Posted Jul 21, 2020 - 16:08 UTC
This incident affected: CA Data Center (Forms).