SMS Status Delays

Incident Report for ClickDimensions

Resolved

This issue has been resolved.
Posted Aug 07, 2025 - 15:05 UTC

Identified

We're currently experiencing a delay in syncing SMS status updates to your CRM. Please note, this does not affect the sending or delivery of your SMS messages — all messages are still being sent and delivered as expected, with full content intact.
The delay only affects how quickly the delivery status appears in your system. As a result, some messages may temporarily appear as unsent or pending, even though they have already been delivered.
We’re working to resolve this and will keep you updated. Thanks for your patience, and please reach out to support if you have any questions.
Posted Jul 31, 2025 - 16:23 UTC
This incident affected: US Data Center (SMS).