Campaign Automation Participant Progression Delays
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 14:43 UTC
Monitoring
We are no longer seeing discernible processing delays.
Posted Feb 28, 2020 - 18:53 UTC
Investigating
We are currently investigating this issue.
Posted Feb 27, 2020 - 16:26 UTC
This incident affected: US Data Center (Campaign Automations) and EU Data Center (Campaign Automations).