Service Incident (AU) - Delay of more than 30 minutes when sending Email Sends
Incident Report for ClickDimensions
Resolved
This service incident has being removed following extensive review from our engineering team. if you have any issues with the email functionality in the AU data centre, please reach out to ClickDimensions Support.
Posted Jun 17, 2024 - 09:22 UTC
Investigating
We are currently investigating this issue.
Posted Jun 17, 2024 - 03:27 UTC
This incident affected: AU Data Center (Email).