Email Preview Service Degradation
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 13:38 UTC
Identified
We have identified a service degradation in our email preview function. We are working with our service provider to restore functionality to normal levels.
Posted Nov 19, 2024 - 13:09 UTC
This incident affected: US Data Center (Email), EU Data Center (Email), AU Data Center (Email), and CAN Data Center (Email).