Service Incident (EU) - Issue with Loading ClickDimensions Hosted Pages
Incident Report for ClickDimensions
Resolved
This incident has been marked as resolved. Please reach out to ClickDimensions Support if you are seeing continued issues with pages loading.
Posted May 23, 2024 - 13:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Please reach out to ClickDimensions Support if you are seeing continued issues with pages loading.
Posted May 22, 2024 - 16:10 UTC
Investigating
We are currently investigating an issue affecting ClickDimensions hosted pages (editors, builders, settings and configuration pages) and preventing them from loading for some clients.
Posted May 22, 2024 - 14:42 UTC
This incident affected: EU Data Center (Campaign Automations, Email, Email Statistics, Eventbrite Connector, Forms, GoToWebinar Connector, Image Manager, Import Tool, Landing Pages, Lead Scoring, Marketing Calendar, SMS, Social Posting, Subscription Management, Surveys).