Option to add an image Block in the Email Designer is not available
Incident Report for ClickDimensions
Resolved
This incident has being resolved.
Posted Jun 14, 2024 - 15:50 UTC
Investigating
We are aware of an issue in relation to the Email Designer functionality where it is currently not possible to add an image block to the template, and are actively working on a fix.
Posted Jun 14, 2024 - 11:15 UTC
This incident affected: US Data Center (Email), EU Data Center (Email), AU Data Center (Email), and CAN Data Center (Email).