Incident Description: Customers reported display issues with certain social icons in historical emails created using the legacy drag-and-drop editor. This affects emails sent prior to December 22, 2024 @15:00 UTC.
Issue Summary: On Friday 13th December 2024 – Microsoft issued an advisory that one of their partners who managed historical Content Delivery Network (CDN) URL's were being retired urgently. On Thursday 19th December, a further advisory was issued that the partner had entered chapter 11 bankruptcy proceedings in the US. This partner's service supported the social icons used in emails created using the legacy drag-and-drop editor that were sent before December 22, 2024 @15:00 UTC. Where a display issue presents, the links work correctly when clicked.
On Friday 20th December 2024 – the historical URL service unexpectedly failed and our advice from Microsoft is to remove all references to the historical URL to restore normal service. All emails sent or scheduled to be sent on or after December 22, 2024 @15:00 UTC are unaffected and social icons display correctly.
Is there anywhere else I can get information from Microsoft on this failure? Yes – here is the current retirement notification from Microsoft regarding Edgio CND services. At time of writing, the FAQ section highlights that the original retirement date was November 2025. https://learn.microsoft.com/en-us/azure/cdn/edgio-retirement-faq
Posted Dec 22, 2024 - 17:41 UTC
Monitoring
We discovered an issue where some social links displayed as broken icons, although the links themselves functioned correctly. This issue arose due to a change in Microsoft’s Content Delivery Network (CDN). We are actively working with Microsoft to determine whether this was an intentional update, a temporary adjustment, or an unintentional issue on their end.
Once identified, the Click engineering team promptly implemented a solution to prevent this problem from occurring in future email sends. However, emails previously sent using the drag-and-drop editor that relied on core social icon imagery will continue to display broken icons (while remaining clickable). We are collaborating with Microsoft to explore a resolution for these previously sent emails.
Posted Dec 20, 2024 - 18:52 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 20, 2024 - 18:34 UTC
Identified
We have identified an issue where certain social links are appearing as broken icons. While this has been resolved for future emails, some historical emails contain links causing the icons to appear broken. A support ticket has been opened with Microsoft to determine if previous links can be restored. Please note that this issue only affects emails created using the Drag-and-Drop Editor and does not impact emails created with other editors.
Posted Dec 20, 2024 - 15:02 UTC
This incident affected: US Data Center (Email), EU Data Center (Email), AU Data Center (Email), and CAN Data Center (Email).