Delays with ClickDimensions Import Tool
Incident Report for ClickDimensions
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 17:01 UTC
Investigating
We are currently investigating this issue.
Posted Mar 25, 2020 - 15:05 UTC
This incident affected: EU Data Center (Import Tool).