Email Sends not sending - US Data Centre

Incident Report for ClickDimensions

Resolved

This incident has been resolved. If you are unsure about whether your Email Send has been successfully sent, please feel free to contact Click Support to verify that before cloning and resending.
Posted Jul 30, 2025 - 15:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2025 - 14:40 UTC

Investigating

We are currently aware of an issue regarding the Email Send functionality on the US Data Centre. Customers may see their emails are failing to send from their CRM.
Posted Jul 30, 2025 - 14:03 UTC
This incident affected: US Data Center (Email).